All CURC services have been restored following Xcel’s protective power outage. Alpine, Open OnDemand, Data Transfer Nodes, Globus, and PetaLibrary should now be functioning as expected. Most Blanca nodes have been restored; however, we are still working to resolve issues affecting a small number of nodes. These nodes will remain under a reservation until they are restored.
Posted Mar 15, 2026 - 12:40 MDT
Identified
Verification of all services is underway.
Posted Mar 15, 2026 - 09:55 MDT
Update
Restoration of all services is in progress.
Posted Mar 15, 2026 - 08:26 MDT
Update
All services will remain unavailable until further notice.
Posted Mar 14, 2026 - 18:39 MDT
Update
All services have been disabled/shutdown.
Posted Mar 14, 2026 - 11:19 MDT
Update
CURC has received notice that Xcel Energy may conduct protective power outages affecting the CU Campus tomorrow afternoon, Saturday, March 14th. Xcel reports that this power outage may last for a period of 4 to 5 hours. However, an additional 24-72 hours may be needed to restore impacted lines/areas of the grid.
All on-premises CURC services, including Alpine, Blanca, Open OnDemand, Data Transfer Nodes, Globus, and PetaLibrary will be impacted. In order to minimize impact to customers and systems, access to these CURC services will be disabled beginning at 9:30 AM tomorrow, March 14th. Due to the outage, jobs may need to be terminated and requeued.
Please follow the CURC Statuspage for updates on the restoration of these services.
Posted Mar 13, 2026 - 16:17 MDT
Investigating
We have placed a reservation for 9:30am Saturday Mar 14 in preparation for weather-related power shutdowns. We will provide more information after RC receives additional guidance from campus leadership
Posted Mar 13, 2026 - 15:09 MDT
This incident affected: Research Computing Core, Alpine, Blanca, PetaLibrary, Open OnDemand, and Science Network.